3
Answered

KLWP installed presets

Hello, I have a Galaxy S8+ and was having an issue previously where the desktop wallpaper would reset back to the default randomly but most common on a restart. I have since then factory reset my phone and for a while my setup was working flawless and when rebooting would pick up right where I left off.

Well like a little kid in a candy store, I went overboard on installing KLWP presets. It was then I noticed two things;

  1. It would take a while to load the installed presets, in fact I had to increase my screen timeout to 1 minute otherwise I would have to restart my loading process. However this is obviously due to limitations outside of your scope and more of hardware limits.
  2.  The desktop wallpaper started periodically resetting to default again.

My thinking is either the presets are being read too slow or KLWP is running out of RAM and crashing? Clearly the wise step on my end is to delete some unused presets but I was thinking KLWP could possibly get better performance by splitting all of the presets into pages. Maybe 10-20 presets a page oppose to loading every preset in your arsenal at once. Also, if KLWP is running in the background for the desktop wallpaper, is it trying to hold/cache a list of all of your presets in the background as well?

Long story short, it might cut issues back by splitting the installed presets into pages. Just an idea, but I love the app and keep up the good work. The flexibility this app brings to phones without the need for root cannot be beat!

2 replies

A preset cannot take 1 minute to load can you send it to me at help@kustom.rocks so i can test it?

Sorry, not a single preset but the list of presets when going to load preset. My screen timeout was 10 seconds and it would timeout, I put it to 1 minute on the safe side but my list of presets takes between 10 and 30 seconds to load. Single presets are not bad on loading but yeah I was getting at putting the list of all of your presets into pages. Not sure if that would impact typical background performance but just an idea.

It just seems coincidental that in between having few presets and having too many for my own good that things got wonky, could be wrong but that was my thinking process at least.

*Edit:
Just for clarification, this page.
https://goo.gl/photos/ABMocybyv5Bajogp9

Oh yeah, I saw others where you were thinking the issue may be from external SD cards but my presets are installed on my internal storage, the same as the KLWP app itself. It might be worth inquiring how many presets the users with errors have installed. It is easy to get carried away when KLWP makes these complicated setups so easy to implement lol kudos for that one.

My storage is at:
/storage/emulated

S8+
Nova 5.4-beta3
KLWP Pro 3.26b721608